DNS service is NOT running (2019-02-10)

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

DNS should be running

Actual Behaviour:

pi@ras3:/var/log $ pihole status
[✗] DNS service is NOT running
pi@ras3:/var/log $ sudo service pihole-FTL status -a
● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
Active: active (exited) since Sun 2019-02-10 19:32:41 CET; 2min 30s ago
Docs: man:systemd-sysv-generator(8)
Process: 29194 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUCCESS)
Process: 29200 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

Feb 10 19:32:41 ras3 systemd[1]: Starting LSB: pihole-FTL daemon...
Feb 10 19:32:41 ras3 pihole-FTL[29200]: Not running
Feb 10 19:32:41 ras3 su[29226]: Successful su for pihole by root
Feb 10 19:32:41 ras3 su[29226]: + ??? root:pihole
Feb 10 19:32:41 ras3 su[29226]: pam_unix(su:session): session opened for user pihole by (uid=0)
Feb 10 19:32:41 ras3 pihole-FTL[29200]: dnsmasq: cannot open or create lease file /var/lib/misc/dnsmasq.leases: Permission denied
Feb 10 19:32:41 ras3 systemd[1]: Started LSB: pihole-FTL daemon.

Debug Token:

fua0k0m0p3

Hi,
I tried to get rid of isc-dhcp-server and switch back to dnsmasq, always using pihole. I learned from other posts that I have to disable dnsmasq as it is included in pihole. So I already executed these commands:
sudo service dnsmasq stop
sudo service dnsmasq disable
sudo service pihole-FTL restart
sudo apt-get remove dnsmasq

pihole -r
runs into
[✗] DNS service is not running
waits 120 seconds,
[✓] Starting DNS service
[✗] DNS resolution is not available
and stops.

pi@ras3:/etc/pihole $ pihole restartdns
[✓] Starting DNS service
pi@ras3:/etc/pihole $ pihole status
[✗] DNS service is NOT running

0 Likes

#2

Seems to be solved by

sudo touch /var/lib/misc/dnsmasq.leases
sudo chown pihole:pihole /var/lib/misc/dnsmasq.leases
sudo reboot
0 Likes

closed #3

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes