DNS server not resolving


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

DNS lookup should be successful for devices using pihole as their DNS server. (I have individual devices set manually within their own settings to the IP address of the rpi/pihole for their DNS server)

Actual Behaviour:

Devices cannot resolve urls and say that the DNS is not responding

Debug Token:

rjoi0fesfu

I’ve tried a clean install. Repair/reconfigure. Restarting the Pi and just restartdns. All to no avail. I’m sure I’m just missing something obvious, but for the life of me, I can’t figure out what it is.

Thanks in advance for any help.

Cheers


#2

This problem appears in your debug log - the Pi was unable to communicate with the server.

[i] Default IPv4 gateway: 192.168.0.1
   * Pinging 192.168.0.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

Verify that the assigned IP for the Pi from the router on the WLAN interface is 192.168.0.153 and that the clients have this address in their DNS manual assignment.

Verify the assigned IP on the Pi with ip a from the Pi terminal

Verifty that the Pi can ping the router with ping -c5 192.168.0.1 from the Pi terminal

Verify that the clients can ping the Pi with ping -c5 192.168.0.153 and ping pi.hole from the client terminal.


#3

Thanks for getting back to me. Interesting that showed up as the pi was able to access the web at the time. In any event, I rebooted the pi and the new log shows it can access the gateway. Using the commands you listed, the correct IP shows up and the pi can ping the gateway, but my computer will not ping the pi by name or by IP. Strangely enough, my Xbox one has successfully used the DNS of the pi to connect, but my other devices still cannot.

My Windows 10 computer says “bad value for option -c5” and “ping request could not find host pi.hole. please check the name and try again” respectively when attempting the two commands you listed.

New debug token following reboot: iypb63fn4r