DNS resolution unexpectedly stops after upgrade to 5.0

Fortunately I was eating dinner so I didn't try to download too soon. :slight_smile: I've done the update and will keep monitoring. Thanks for keeping on top of this.

1 Like

@DL6ER It would be awesome if this can land in v5.2 as well!

Does that mean you found the issue @DL6ER?

No, it is the

Which is terminated for v5.1.1.

All are waiting for your next crash log :wink:

The regular update ran overnight and looking at both the logs and the monitoring I have I don't see any evidence of delays at all. I ran a couple of pihole -g sessions back to back and that didn't seem to cause any issues. Maybe waiting a few more days makes sense but it seems like the issue has been resolved.

1 Like

It's been a couple of weeks now with no failure. Is it safe to assume that the issue was resolved with some of the code updates?

Are you still using the custom branch? Pi-hole v5.2 has not yet been released we're all awaiting this desperately. It fixes so many problem. Pinging @DanSchaper and @promofaux that the dnsmasq bug which resulted in all the many crashes is still not fixed in master.

You really didn't need to ping me on this.

I'm still running the last version I was asked to run:

Pi-hole version is v5.1.1 (Latest: v5.1.1)
AdminLTE version is v5.1 (Latest: v5.1)
FTL version is tweak/gravity_counting_logging vDev-7a76944 (Latest: v5.1)

@dkozinn Thank you very much for your testing. This kind of input is what we are largely builing on and what helps us making Pi-hole an even better software!

We're getting the last pieces into place for the v5.2 release which will include all the fixes, so also this one. After the release, you can run

pihole checkout master

to get back on the main track. However, I wouldn't do it already now (you'd loose the fix).

I'm happy that I can help give back a little to the project. I'll stay on this as long as you like.

1 Like

@dl6er I see that 5.2 has been released, can I go ahead with moving back to master now?

Yeah, please to this to pick up the latest code and return to the stable version:

pihole checkout master

I've done that and am now back on the master branch. Thanks again for the help.

1 Like

@dl6er One other thing: I think I'm still seeing debugging info in pihole-FTL.log in that I see the DB queries and such. Is that normal or is there something I need to turn off to stop that?

The pihole-FTL.conf file should be almost empty. Check your /etc/pihole/pihole-FTL.conf for any DEBUG_* settings. You can even delete this entire file if there is nothing special inside. Pi-hole will then use the defaults for its DNS engine (it will still use your configured DNS servers, etc. which are stores elsewhere).

It had DEBUG_DATABASE set to true, so I removed that which did the trick. The only other thing is PRIVACYLEVEL=0, which is fine.

Thanks again.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.