DNS resolution error with Ubuntu, but with OpenWRT

Hy, i'm sorry but my english is not good. Three days ago i've installed pihole inside a docker container, and it worked well. But when i restarted it, nothing worked anymore. Everytime that i create or start pihole it give me this error:

  [✗] DNS resolution is currently unavailable

I tried to recreate it with docker compose, with Portainer and manually with some docker commands. Also by setting the network as host (as well as mcvlan) and by reinstalling ubuntu server. The web interface also doesn't start, and when (luckily) starts it show that all the request are N/A.
While troubleshooting this i discovered that docker listen only with ipv6 on port 53 (and i don't know what to do about this), and, no matter what i tried, inside the container the dns resolution doesn't work but i can ping every ip i want.
I tried also to reset the router, and nothing changed, but in order to give internet to my server i'm using an old router with openwrt that recive via wifi and sends out via ethernet cable. I tried to change some setting about the traffic roules, but i don't know what to do because the host work normally (i've disabled DNSStubListener).
Obviously i cannot upload even the debug. Thanks to everyone!

[edit] I've discovered that pihole "locks" dns resolution inside the other container on the same bridge. I'm getting so confused...