DNS and FTL not working after reboot or power cycle.

Running pi-hile on a beaglebone black with debian 9.5 IoT (current). Sorry it’s not a Pi, but it’s what I had and some people already decent instructions on making it work.

After the setup was completed the DNS and FTL services show as offline and it do not work.

I found this fix which works to get the services running, but after a reboot or power cycle things are broken again until I repeat these commands.

sudo mv /etc/dnsmasq.d/SoftAp0 ~
sudo service pihole-FTL restart

I read on and tried some other suggested commands to make the fix work after restart/boot but they did not work?

sudo touch /var/lib/misc/dnsmasq.leases
sudo chown pihole:pihole /var/lib/misc/dnsmasq.leases
sudo systemctl restart pihole-FTL
grep -v ‘#|^$’ -R /etc/dnsmasq.*
sudo mkdir /var/lib/misc
sudo touch /var/lib/misc/dnsmasq.leases
sudo chown pihole:pihole /var/lib/misc/dnsmasq.leases

I apologize being a newbie so often I don’t fully understand what the commands do.

Debug token is: https://tricorder.pi-hole.net/9meonp3npc

Thanks

Shere was a discussion about that file here:

See if anything here helps with your situation regarding the /etc/dnsmasq.d/SoftAp0 file.

I tried to remove the following line

echo “cache-size=2048” >> ${wfile}

from the script /opt/scripts/boot/am335x_evm.sh

unfortunately it didn’t help.

I don’t have an answer for you as I am not familiarized with any softap requirements/parameters/dependencies.

You could write a script that gets triggered @reboot with a small delay that does the delete for your and restarts pihole-FTL …