# DHCP not working with "Too few arguments" error log

**URL:** <https://discourse.pi-hole.net/t/dhcp-not-working-with-too-few-arguments-error-log/10825>\
**Category:** Help\
**Created:** [July 11, 2018, 6:23pm UTC](https://discourse.pi-hole.net/t/dhcp-not-working-with-too-few-arguments-error-log/10825 "2018-07-11T18:23:41Z")\
**Posts on this page:** 1\
**Showing post:** 10

<div class="post-metadata">

**Author:** ![RamSet](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/ramset/32/3497_2.png) [@RamSet](https://discourse.pi-hole.net/u/RamSet)\
**Post date:** [July 11, 2018, 7:22pm UTC](https://discourse.pi-hole.net/t/dhcp-not-working-with-too-few-arguments-error-log/10825/10 "2018-07-11T19:22:10Z")

</div>

Your best option at this point is to use FTLDNS beta.

> [@Help Us Beta Test FTLDNS](https://discourse.pi-hole.net/t/help-us-beta-test-ftldns/8224):
>
> Originally published at: [https://pi-hole.net/2018/03/24/help-us-beta-test-ftldns/](https://pi-hole.net/2018/03/24/help-us-beta-test-ftldns/)[In case you missed it](https://pi-hole.net/2018/02/22/coming-soon-ftldns-pi-holes-own-dns-dhcp-server/), FTLDNS[™](https://pi-hole.net/trademark-rules-and-brand-guidelines/) is Pi-hole's Faster Than Light (FTL) daemon combined with a DNS/DHCP server (our fork of dnsmasq). So instead of installing dnsmasq as a dependency, we will be distributing all services in a single binary. This will allow us to hook into dnsmasq's functionality at a code- level, as well as ensuring that you are using the latest stable version of the resolver and receive, e.g., i…

I think because your environment already has an embedded dnsmasq, it will cause a lot of headaches trying to isolate the issue with it.

FTLDNS beta does not need dnsmasq to work any longer.

You would most likely have to disable dnsmasq from running so that FTLDNS can take over port 53.

The installer WILL fail at starting DNS. It is to be expected since dnsmasq is active and using port 53.

After install, I recommend editing `/etc/systemd/resolved.conf` and un-commenting `DNSStubListener=yes` and change it to `DNSStubListener=no`  
then run `sudo systemctl restart systemd-resolved`.

This should release port 53 and you'd be able at this point to start pihole-FTL as your DNS resolver with  
`sudo systemctl start pihole-FTL.service`

---

_[View the full topic](https://discourse.pi-hole.net/t/dhcp-not-working-with-too-few-arguments-error-log/10825)._
