DHCP confused


root@coqui:/home/soydepr# grep -i dhcp /var/log/auth.log

Oct  8 04:07:50 coqui sudo: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole -a addstaticdhcp B8:27:EB:D3:CD:B5 coqui
Oct  8 16:24:04 coqui sudo: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole -a addstaticdhcp B8:27:EB:78:2F:47 vorman
Oct  8 19:14:32 coqui sudo:  soydepr : TTY=pts/0 ; PWD=/etc/dnsmasq.d ; USER=root ; COMMAND=/usr/bin/pico 04-pihole-static-dhcp.conf
Oct  8 19:16:05 coqui sudo: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole -a disabledhcp

Have a quick question .

I am trying to set up dhcp via pihole . However i have not enabled .
Yet in syslog i see above entries . Is pihole still assigning ip eve though i have not enabled it ?


Please run a debug log and post the token here. Thanks.


6d67v36o71. Thanks


Since i didn’t hear back i went ahead and turned on dhcp settings knowing that i cant disable in my isp router which is where pihole is pointing to .

Who is giving the final assignment my isp router or pinole as i see entries in both places ?
One device i dont see is Sony Bravia 4K which i am trying to filter .
Was not able to set setting in tv itself


You are seeing which entries in which both places? From what isn’t obscured, your leases look normal.

If you have DHCP enabled on the Pi-Hole, it should be disabled on the router. Then all the DHCP assignments will be made by the Pi-Hole.

If you aren’t seeing the TV on the lease list, I would unplug the TV for about 30 seconds, then plug it back in and force it to get a new DHCP lease.


When i say both list i mean leases in my router IN pihole.
As i said i can’t disable dhcp in my router so i need to get a new one

What can go wrong I’f i cant disable dhcp in route


With two DHCP servers on the network, they may try to assign the same IP. So typically you don’t want two on the network. If you do use two, they have to be set to provide IP addresses on non-overlapping ranges. Example would be:

Router provides IP range 1-100
Pi-Hole provides IP range 101-200

I think the answer to your question is no. If DCHP is not enabled on Pi-Hole, it’s not assigning IP addresses.

If your Pi-Hole was working properly with DHCP turned off on Pi-Hole, then go back to that setting. Your debug log you uploaded doesn’t show any problems.


But what should happened if they assigned 2 different ip. Or will one respect the other and not assign it if assign already


Once a client has a lease with an IP, it won’t get another one assigned in addition. But there is nothing to prevent the other DHCP server from assigning that same IP to another client if it’s on the same IP range.


Final question on this topic

Who assigned vegas pro my router or pihole

Also now can I safely remove dnsmasq


From the pictures, it looks like Pi-Hole assigned that IP. Check your router and see what it lists for DHCP clients.


Dnsmasq is embedded into FTL, so you can remove the standalone dnsmasq package.


But why pihole writes here

root@coqui:/etc/dnsmasq.d# ls -lash
total 32K
4.0K drwxr-xr-x   2 root root 4.0K Oct 11 11:32 .
 12K drwxr-xr-x 145 root root  12K Oct  7 20:23 ..
4.0K -rw-r--r--   1 root root 1.5K Oct 10 20:42 01-pihole.conf
4.0K -rw-r--r--   1 root root  481 Oct 10 18:37 02-pihole-dhcp.conf
4.0K -rw-r--r--   1 root root   94 Oct  8 19:14 04-pihole-static-dhcp.conf


Same as pihole


Therefore, dnsmasq still runs the same as it did before, and it uses the same paths as it did before.


Thanks , interesting

After further review i see my router assign some and pihole assigning others …

How i kill unknown host until i fuigure out what it is

9C:E3:3F:D0:AA:D7 unknown


The device with this MAC ID and assigned IP is a client, not a host. You may be able to temporally block this MAC address from your network with router settings. Or, by process of elimination on your network, figure out what this client is and unplug it.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.