Dashboard shows zero results, all clients use pihole for DNS


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

The dashboard should show top clients, queries, etc

Actual Behaviour:

All the dashboard dials are at zero except “Domains on Blocklist”. Pihole is running DHCP server, all clients resolve an IP from pihole with correct DNS, ads are blocked on all devices as they should be. There is just no log of how much the pihole is blocking.

Debug Token:

t01uoak541


#2

What’s the output when you run

echo ">stats" | nc 127.0.0.1 4711

on your Pi-hole?


#3

pi@raspberrypi:~ $ echo “>stats” | nc 127.0.0.1 4711
domains_being_blocked 125586
dns_queries_today 0
ads_blocked_today 0
ads_percentage_today 0.000000
unique_domains 0
queries_forwarded 0
queries_cached 0
clients_ever_seen 0
unique_clients 0
status enabled
—EOM—

Is that good?


#4

That looks good. It also looks like no DNS queries were processed.

How do you use the Pi-hole DNS? Did you manually specify the Pi-hole IP as your DNS server on your clients or do you use Pi-hole as your DHCP server?

What’s the output of

nslookup flurry.com and then the same echo ">stats" | nc 127.0.0.1 4711 ?


#5

There aren’t any queries in the log since 12am this morning. Try restarting dnsmasq:

sudo service dnsmasq restart

#6

Pihole runs DHCP. I have a standard network set up, except that I am running meraki switch and AP. They are set to work as basic L2 devices with no fancy features enabled, but I cant help but think they are blocking something.

pi@raspberrypi:~ $ nslookup flurry.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: flurry.com
Address: 192.168.20.253

pi@raspberrypi:~ $ echo “>stats” | nc 127.0.0.1 4711
domains_being_blocked 125586
dns_queries_today 0
ads_blocked_today 0
ads_percentage_today 0.000000
unique_domains 0
queries_forwarded 0
queries_cached 0
clients_ever_seen 0
unique_clients 0
status enabled
—EOM—


#7

Ran the command, no change in logs. When I go to https://blockads.fivefilters.org/?pihole it tells me ads are blocked.


#8

Make a new debug token.


#9

Your debug token is: yn2ig3od1n


#10

Your dnsmasq config file does not have the correct settings for FTL to be able to read the log.

Run pihole -r to repair and it should fix it.


#11

Thanks, that worked after a fashion.

I ran pihole -r for no effect, then I ran apt-get update and apt-get upgrade, then pihole -r again. My counters started changing straight away.

Thanks again!