Configuring Pi-Hole with Tomato Shibby


#1

I’m trying to get Pi-Hole configured with Tomato Shibby. I’m using:
Tomato Firmware 1.28.0000 MIPSR2-140 K26 USB AIO-64K

I don’t see a Static DNS config area under Basic > Network. Here’s what I have:

I can switch the DNS server to Manual then have these options:
WAN%20DNS

However, tried with the settings you see above, I didn’t get it working.

I focused on using the method described in step 2 on: How do I configure my devices to use Pi-hole as their DNS server?

Under Advanced > DHCP/DNS I added the Dnsmasq configuration and took an educated guess at the rest of the settings.

I did some searching online, but haven’t been able to get anywhere with it.

There’s another page of Dynamic DNS settings - not sure if that’s relevant?

Am I missing something obvious?

Expected Behaviour:

DNS Service running

Actual Behaviour:

DNS Service Not Running

Debug Token:

There was an error uploading but included some parts that had failures here:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
shuf: /etc/pihole/gravity.list: No such file or directory
dig: ‘’ is not a legal name (unexpected end of input)
[✗] Failed to resolve via localhost (127.0.0.1)
dig: ‘’ is not a legal name (unexpected end of input)
[✗] Failed to resolve via Pi-hole (192.168.1.21)
[✓] doubleclick.com is 172.217.12.142 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Pi-hole processes
[✗] dnsmasq daemon is failed
[✓] lighttpd daemon is active
[✗] pihole-FTL daemon is unknown

*** [ DIAGNOSING ]: Dashboard and block page
[✗] X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Content-type: text/html; charset=UTF-8
Date: Wed, 30 May 2018 00:43:44 GMT
Server: lighttpd/1.4.35


#2

This would be the correct spot for it.

You want to disable Use internal DNS in the DHCP/DNS server (LAN) page.

Nope, has nothing to do with it :slight_smile:

On the Pi-hole device, you seem to have some errors though.

What device do you have this installed on ?


#3

Thanks!

It’s an RPi 2 B running Raspbian (99% sure, I’m not looking at it right now). I have an RPi 3 B sitting around that I was going to save up for some future trouble-making, but can put it into use if it’d help.


#4

Make sure you are not running an outdated version of the OS so that Pi-hole does not face incompatibility issues.


#5

I ran update && upgrade - which would cover that right?


#6

not really.

What’s the output of :
cat /etc/os-release


#7

Ah ha!

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

#8

#9

Thanks for helping me hunt this down. I’ll fix this, then hopefully come back with my own solution to the topic title :grin: for anyone else looking up how to do this.


#10

Ok, I got everything set up and working. Had to restart some machines for everything to take effect, but it’s running and working well.

Here are the settings I ended up using – seems obvious now that I solved the other issue, but this may help someone else get set up quickly, so here we go:


Under Basic > Network. The DNS 1 and DNS 2 won’t appear until you change DNS Server to Manual.

The IP address of my pi-hole machine was 192.168.1.21 - you should substitute with the ip address of yours, naturally.


Under Advanced > DHCP DNS these are my settings.


On Pi Hole Settings > DNS this is what I have.

So far so good. I’m most pleased with the in-app ad blocking on my phone… :relieved:


#11

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.