Conditional forwarding.. What is wrong?

hi again,

I set up conditional forwarding but it is still showing clients with ip addresses.

here is my settings;



what is wrong here?

Stable version 4 release still depends on local resolver being Pi-hole.
Check below if other than

pi@noads:~ $ tail /etc/dhcpcd.conf
interface eth0
  static ip_address=
  static routers=
  static domain_name_servers=

pi@noads:~ $ cat /etc/resolv.conf

pi@noads:~ $ dig +short @ chaos txt version.bind

pi@noads:~ $ dig +short @ -x

Beta version 5 doesnt need as local resolver.

here are my results;

root@raspberrypi:~# tail /etc/dhcpcd.conf
interface eth0
        static ip_address=
        static routers=
        static domain_name_servers=
root@raspberrypi:~# cat /etc/resolv.conf
root@raspberrypi:~# dig +short @ chaos txt version.bind
root@raspberrypi:~# dig +short @ -x
empty result is my pc's ip.

I gave a static ip to my pc from static mac/ip mapping section of dhcp service from the router. is this affects the resolve?

I removed pc from static ip list but still don't resolve it's name.

I forgot to say, I'm also using dnscrypt.

Does your router know the name for your PC's IP ?

dig +short @ -x

yes it does.

Please use the dig I provided to query your router for a name from your Pi-hole machine.

(And consider obfuscating the MAC address in your screen shot. As a globally unique address, that's sensitive information potentially usable to track you)

dig +short @ -x
empty result.

thanks for your suggestion to hide mac address.

This means your router is not answering requests for reverse (IP to hostname) lookups, although your screen shot shows that it indeed knows the name.

There is nothing that can be done on the Pi-hole side to mitigate this.

You'd have to search your router's documentation for a solution.

It could help to provide your router's make and model, to catch the attention of users with the same or similar device. You might even consider to put that straight in your topic's title.

thanks for everything.

my router model is ubiquiti edgerouter 4. as you said maybe some users have similar device.

Lucky you - I have access to an EdgeRouterX :wink:

Assuming that this is similar to your ER4, you may try to enable dnsmasq as your router's DHCP server, as the default ISC DHCP server won't push known names to its internal DNS:
EdgeRouter - DHCP Server Using Dnsmasq.

And if above doesn't work:

I enabled dnsmasq at router and now it is resolving names. thank you all again.

1 Like