Client's names not resolving

Please follow the below template, it will help us to help you!

Expected Behaviour:

Seeing individual hostnames instead of only showing hits from the router

Actual Behaviour:

Only seeing localhost and main router

Debug Token:

[Replace this text with the debug token provided from running pihole -d (or running the debug script through the web interface]

I edited /etc/hosts with the ips and hostnames given out by the router’s DHCP yet I only see 192.168.1.1 as client along with localhost

Please provide a debug token as requested in the template.

Sure thing
https://tricorder.pi-hole.net/5339og6f4i

Most likely, you have setup your Pi-hole as your router’s upstream DNS.

While this filters all DNS traffic in your local network, Pi-hole will see all DNS requests as originating from a single machine: your router.
DNS queries will travel like this, e.g.:
Laptop -> Router -> Pi-hole -> Pi-hole’s upstream DNS server
Smartphone -> Router -> Pi-hole -> Pi-hole’s upstream DNS server

To change this, try reconfiguring your router to

  • use local DNS-resolution (required)
  • disable upstream DNS resolution (optional)

By handing out Pi-hole as local DNS server to your clients, they will ask your Pi-hole directly, allowing Pi-hole to see the correct origin of DNS queries.
DNS queries will travel like this, e.g.:
Laptop -> Pi-hole -> Pi-hole’s upstream DNS server
Smartphone -> Pi-hole -> Pi-hole’s upstream DNS server

If your router does not offer diverting DNS to a local DNS server, you can configure each device manually to use Pi-hole as DNS.

The forum may have advice on how to do setup local DNS resolution with your specific router model, try searching for your router model.
As starting point, refer to How do I configure my devices to use Pi-hole as their DNS server?

Yes you were right I fixed it by using proper dns under wan then using router IP under dns settings for the pihole. Everything is working fine, however when I connect through my VPN, (router running VPN server) it’s not using the pihole, thus no ad blocking. Should I uncheck advertising dns under VPN server settings ,?

Settng up VPN to use Pi-hole is a different topic altogether, and one I am not familiar with.

I’d advise you to search the forums, and if you don’t find any helpful hints, start a new topic for this, while marking this one as solved.

Your chances for a knowledgable answer are better if your topic is specific enough for drawing the right people’s attention :wink:

1 Like

I sorted it out here’s what I did for anyone with same issue.
After applying what has been suggested earlier in the thread. I used dnsfilter on the Android phone using the pihole IP as dns and also disabled dns advertising in the OPENVPN server config

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.