Change ip of pi-hole so it isn't locahost

Hi guys, I can't seem to find this answer anywhere (reddit etc) I have setup pihole on my Mac through docker. It has used localhost as the IP, so I can't connect to it through any other machines because it tries routing itself through its own localhost lmao. How do I go about changing the address its on atm?

You are probably having difficulties with Docker's network isolation.

If this is your first contact with Docker, read a bit about Docker's network options first. Then decide on the network driver you want to use.

If unsure, running Docker in host mode may not be the worst option to start with, especially if Pi-hole would be the only container you run. You can always switch to another driver later on.

Pi-hole's Docker documentation has additional information on tweaking certain environment variables for specific modes.

Ok that definitely helps, I read the article and It looks like macvlan is my best option here, I don't run anything else on docker but pi hole so I'm ok in that regard.