Can't Update to 5.0 Beta

I tried to install the 5.0 Bata on my 2nd PiHole (Rasberry PI) today but kept getting the error message
"Branch change has been canceled"

Seemed as if i was running a custom branch based on other search so I uninstalled PiHole and re-installed it. Got it back up and running, checked PiHole - Up, and got this message.

[i] Pi-hole Core: up to date
[i] Web Interface: up to date
[i] FTL: up to date
[i] Warning: You are using FTL from a custom branch (release/v5.0) and might be missing future releases.

Seems like the FTL service updated to 5.0 but the rest of the services did not. I tried doing both a reconfigure and repair and than running the V5 upgrade script again but I keep getting stuck on that custom brach issue.

Any ideas?

What is the output of pihole -v

Pi-hole version is v4.4 (Latest: v4.4)
AdminLTE version is v4.3.3 (Latest: v4.3.3)
FTL version is vDev-5b0cfb5 (Latest: v4.3.1)

I was able to roll back to FTL 4.3.1 using

pihole checkout ftl master

Still getting the Custom Branch issue when trying to install the Beta though.

The current beta will look like this (with a release/v5.0 indicated for each of the three Pi-hole parts):

  Pi-hole version is release/v5.0 v4.3.5-486-g393c773 (Latest: v4.4)
  AdminLTE version is release/v5.0 v4.3.2-488-g34d99428 (Latest: v4.3.3)
  FTL version is release/v5.0 vDev-5b0cfb5 (Latest: v4.3.1)

I get that I just can't figure out how to install it when I run the

echo "release/v5.0" | sudo tee /etc/pihole/ftlbranch
pihole checkout core release/v5.0
pihole checkout web release/v5.0

I get "Branch change has been cancelled"

Which seems to indicate I am running off a custom branch, however I have installed and configured from PiHole site. So Not sure how to get around the Branch change has been cancelled message

Please post the output you are seeing when you run the update commands.

echo "release/v5.0" | sudo tee /etc/pihole/ftlbranch
pi@raspberrypi:~ $ pihole checkout core release/v5.0
  Please note that changing branches severely alters your Pi-hole subsystems
  Features that work on the master branch, may not on a development branch
  This feature is NOT supported unless a Pi-hole developer explicitly asks!
  Have you read and understood this? [y/N] y

  [i] Branch change has been cancelled

Are you typing that in or copy/pasting? And what is the locales for your setup configured to?

I had been copy and pasting it al as one command. I'll try typing it.

How do I find the locales

Just type locale and you'll get a list.

And type the checkout command as well.

pi@raspberrypi:~ $ locale
1 Like

Thanks, the locales all look good.

When I tried typing the sudo I got.

$ echo "release/V5.0" | sudo tee /ect/pihole/ftlbranch

tee: /ect/pihole/ftlbranch: No such file or directory


If I manually create that directory will it cause an issue?

Check the /ect/pihole/ftlbranch there's a typo (/etc/ not /ect)

Typical typo on my end. the install seems to be working.

Odd the Copy and paste caused the original issue. Good thing to know moving forward. Thank you for your help!

1 Like

Sometimes a copy will include whitespace characters that you cant see but the computer will still act on them. The checkout command saw the y plus some invisible characters and aborted to be safe. It will only change the installed software if it specifically sees y or yes. Anything else will cancel the process.

1 Like

Super helpful!