Can't access Raspberry Pi (or internet) with Pi-hole as DHCP Server

Expected Behaviour:

Setting Pi-hole as DHCP and disabling the router as DHCP should allow the Pi-hole to act as the DHCP

Actual Behaviour:

Setting Pi-hole as DHCP and disabling the router as DHCP disables all connectivity to Pi and external.

Debug Token:

https://tricorder.pi-hole.net/t1211ucdvc

Your debug log shows that the Pi-Hole DHCP server is not active. Was this turned off to go back to router DHCP?

DHCP_ACTIVE=false

Your debug log also shows this activity in the past 24 hours prior to the time shown below. Was this also with the router providing DHCP?

   [2019-03-03 12:39:45.945 14644] Imported 7363 queries from the long-term database
   [2019-03-03 12:39:45.946 14644]  -> Total DNS queries: 7363
   [2019-03-03 12:39:45.946 14644]  -> Cached DNS queries: 805
   [2019-03-03 12:39:45.946 14644]  -> Forwarded DNS queries: 5041
   [2019-03-03 12:39:45.946 14644]  -> Exactly blocked DNS queries: 836
   [2019-03-03 12:39:45.947 14644]  -> Unknown DNS queries: 681
   [2019-03-03 12:39:45.947 14644]  -> Unique domains: 632
   [2019-03-03 12:39:45.947 14644]  -> Unique clients: 16
   [2019-03-03 12:39:45.947 14644]  -> Known forward destinations: 2

After you changed from router DHCP to Pi-Hole DHCP, did you reboot the router and renew the DHCP leases on all connected clients?

Interested to follow this… not to say I had the same issue because I didn’t realise this group was here and already reinstalled several times. However I felt it was every time I tried to use the Pihole as dhcp it would fall over the same way you have described. Cheers.

What @jfb describes is one of the most important steps of the process (renewing the leases on the clients, not necessarily rebooting the router). Without doing this, the clients will not be aware of the new DHCP server and the clients may stay partially uninitialized.

You can always connect to the Pi even when no DHCP server is running at all by, temporarily, setting a suitable static IP address for your computer and connecting directly to the IP address of your Pi-hole.

Yeah, you’re entirely correct @jfb . Same with you @DL6ER.

Must have had a brain fart, I don’t actually remember restarting the router. I also followed the guide here which doesn’t specify restarting the router, so it may be worth adding that step.

Thanks for the prompt help guys, I’ll give that a crack when I have some time to play with.

Unfortunately restarting the router (or renewing the dhcp leases in general) did not solve the issue.

1 Like

Definitely… once I had moved over from pfSense to Pi-Hole as DHCP. I had stopped all services related to DCHP on pfSense. I then had rebooted both pi and pfSense. Once rebooted and tested on my PC and it was all working, rebooted and test throughout the house and all good.

I found that everything in the house was great, PC, iPads, Xbox etc. was happy. Then after a few hours everything slowly started to crap themselves on the network till nothing could access the internet. ¯_(ツ)_/¯

Okay, now comes the part where you need to look really into what is going on. I’d suggest the following approach:

  1. Create a new file /etc/dnsmasq.d/99-dhcp-debugging.conf and put there only one line:
    log-dhcp
    
  2. Enable Pi-hole DHCP server
  3. Disable router’s DHCP server
  4. Do not renew the lease of your current computer
  5. By 3, you can stay connected to your Pi-hole.
  6. Try to renew the lease on another of your clients (e.g. laptop, smartphone)
  7. Check /var/log/pihole.log and /var/log/pihole-FTL.log if there is something interesting in there. The option log-dhcp will log each and every DHCP action with many details.

If there are no messages related to DHCP in the file, it is very likely that you have set up a firewall somewhere that blocks the DHCP queries from reaching your Pi-hole. IIRC we’ve seen something similar with Google routers (?) which refused to forward DHCP queries of any connected client to the Pi-hole even if you disabled its DHCP server.

1 Like

Thank you and very much appreciated!

I will give this a go now and report back, and to be honest while I’m 100% sure DHCP in pfSense is off, the firewall part of it is quite powerful, so you never know I guess.

Cheers.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.