Cannot update FTL to latest version

Okay, this means your installation was not successful.
What is the output of

cd /etc/.pihole
git status

?

If everything looks okay, you might be able to fix the installation with

cd /var/www/html
sudo git clone https://github.com/pi-hole/AdminLTE.git admin

and then running pihole -r again. If this still doesn’t work, I’m afraid you’d have to reinstall as it would take a long time to figure out what didn’t work exactly during the installation process.

cd /etc/.pihole
git status

gives the output:

On branch master
Your branch is up-to-date with ‘origin/master’.
nothing to commit, working tree clean

I’m not sure what “OK” looks like there. I assume this wasn’t an error message. Testing the sudo command.

The command seemed to run fine and received objects and deltas (not sure what this means).

What was the output of this command.

remote: Enumerating objects: 12, done.
remote: Counting objects: 100% (12/12), done.
remote: Compressing objects: 100% (12/12), done.
remote: Total 19415 (delta 2), reused 3 (delta 0), pack-reused 19403
Receiving objects: 100% (19415/19415), 25.92 MiB | 1.68 MiB/s, done.
Resolving deltas: 100% (10090/10090), done.

Now run pihole -up and see if it updates.

I just ran “pihole -up” and it returned the same result as the first time:

[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL https://github.com/pi-hole/FTL/releases/download/v4.3.1/tbd not found

I’ll be reinstalling it fresh. I really appreciate all the troubleshooting that everyone gave me. I’ll be donating soon for the cause.

Ran one last test of pihole -r and it updated correctly!
Retested the admin page and I’m able to log in!

Everything has the updated versions.

Success!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.