Cannot Resolve DNS

#1

Please follow the below template, it will help us to help you!

This is my first project with my raspberry pi, and I don’t know much about networking, so sorry if this is a basic question. I installed pi-hole onto my pi, and changed my router settings to use the ip of my pi as the dns server. I also reserved the address of my pi. I tried the suggestions from other threads, but still can’t get it to work. I think I’m probably overlooking some simple setting within my router. Does anyone have any suggestions? Thank you!

Expected Behaviour:

Resolve DNS

Actual Behaviour:

Timeout? Every web page I try to access ends says that it couldn’t find the ip address

Debug Token:

4okqi6oh66

0 Likes

#2

How did you connect your raspberry pi to the router?

Via network cable or Wifi ?

If it’s with a network cable, you will need to have Pi-hole set-up as listen to eth0 as the interface or wlan0 for WiFi.

How is it set-up ?

0 Likes

#4

Are you using 192.168.1.11 as your DNS server in your router ?

0 Likes

#5

My raspberry pi is connected to the router with an ethernet cable. I set it to use eth0 from the web app settings in DNS. I have 192.168.1.11 as the DNS server in my router.

0 Likes

#6

What is indicating that Pi-Hole is not working? Your debug log shows it working normally. From a connected client PC or Mac, run the following commands which will show which DNS server is being used:

nslookup pi.hole

nslookup pi-hole.net

nslookup pi-hole.net 192.168.1.11

0 Likes

#7

When I try to access any webpage from my desktop, it times out and says it can’t find the ip.

nslookup pi-hole.net 192.168.1.11 returns
`Server: 192.168.1.1
Address: 192.168.1.1#53

** server can’t find 11.1.168.192.in-addr.arpa: NXDOMAIN
`

and the other two return connection timed out; no servers could be reached

0 Likes

#8

How about this from a desktop client? nslookup pi-hole.net 1.1.1.1

0 Likes

#10

This returns

Address:	1.1.1.1#53

Non-authoritative answer:
Name:	pi-hole.net
Address: 206.189.252.21

Also, I previously mistyped the command nslookup pi-hole.net 192.168.1.11. This returns the same result as above. Sorry about that!

0 Likes

closed #11

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes