BOGUS DOMAIN SERVFAIL suddenly

Hello all, I can suddenly after many years no longer access RedFlagDeals forums at forums.redflagdeals.com

Pi-hole Query Log says BOGUS SERVFAIL

Very little info to be obtained from searching, and I'm just a novice user

Time is synchronized perfectly

Found more here too, unrelated to RedFlagDeals I think

Starting to give me a headache

It's Sunday morning, check your block lists. I suspect the domain is now on one of them. That might explain the 'suddenly'. Also check that is resolvable via your upstream DNS.

Hi there and thanks for the reply! I'm not exactly sure how to do that, I haven't changed anything in a very long time.. I am running Unbound if I recall correctly so I'm not quite sure where to begin. I didn't add any special block lists! It's just always been a stock installation mostly besides the Unbound, and the rest of the internet seems ok (so far!)

Hm...I'm using unbound as well and have a number of block lists. That domain revolves OK for me:

[~]$ dig forums.redflagdeals.com

; <<>> DiG 9.18.21 <<>> forums.redflagdeals.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21910
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;forums.redflagdeals.com.	IN	A

;; ANSWER SECTION:
forums.redflagdeals.com. 300	IN	CNAME	n.sni.global.fastly.net.
n.sni.global.fastly.net. 30	IN	A	151.101.145.91

;; Query time: 85 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Sun Feb 11 07:52:23 EST 2024
;; MSG SIZE  rcvd: 105

You'll probably need to provide a debug log for the devs/mods to inspect.

https://tricorder.pi-hole.net/TSNDQeWd/

Here is the debug log! I see it complain about not being able to resolve stuff via 8.8.8.8 which is one of the public nameservers deliberately blocked at the router level, maybe for some reason my Unbound depends on it?

I use the public-dns.info block list to block a large list of DoH servers on port 53 and a few others, to avoid sneaky devices bypassing DNS like my Fire tablets but it's never been a problem

Maybe I'll have to disable that until mods can help

If the domain were on a block list, the reply would show the domain as blocked, not forwarded to the upstream DNS resolver.

What is the complete output of the following command from the Pi terminal:

sudo grep -v '#\|^$' -R /etc/unbound/unbound.conf*

root@pihole:~# sudo grep -v '#\|^$' -R /etc/unbound/unbound.conf*
/etc/unbound/unbound.conf:include-toplevel: "/etc/unbound/unbound.conf.d/*.conf"
/etc/unbound/unbound.conf.d/root-auto-trust-anchor-file.conf:server:
/etc/unbound/unbound.conf.d/root-auto-trust-anchor-file.conf:    auto-trust-anchor-file: "/var/lib/unbound/root.key"
/etc/unbound/unbound.conf.d/pi-hole.conf:server:
/etc/unbound/unbound.conf.d/pi-hole.conf:    verbosity: 0
/etc/unbound/unbound.conf.d/pi-hole.conf:    interface: 127.0.0.1
/etc/unbound/unbound.conf.d/pi-hole.conf:    port: 5335
/etc/unbound/unbound.conf.d/pi-hole.conf:    do-ip4: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    do-udp: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    do-tcp: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    do-ip6: no
/etc/unbound/unbound.conf.d/pi-hole.conf:    prefer-ip6: no
/etc/unbound/unbound.conf.d/pi-hole.conf:    harden-glue: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    harden-dnssec-stripped: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    use-caps-for-id: no
/etc/unbound/unbound.conf.d/pi-hole.conf:    edns-buffer-size: 1232
/etc/unbound/unbound.conf.d/pi-hole.conf:    prefetch: yes
/etc/unbound/unbound.conf.d/pi-hole.conf:    num-threads: 1
/etc/unbound/unbound.conf.d/pi-hole.conf:    so-rcvbuf: 1m
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: 192.168.0.0/16
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: 169.254.0.0/16
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: 172.16.0.0/12
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: 10.0.0.0/8
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: fd00::/8
/etc/unbound/unbound.conf.d/pi-hole.conf:    private-address: fe80::/10
/etc/unbound/unbound.conf.d/remote-control.conf:remote-control:
/etc/unbound/unbound.conf.d/remote-control.conf:  control-enable: yes
/etc/unbound/unbound.conf.d/remote-control.conf:  control-interface: /run/unbound.ctl
root@pihole:~# 

Thank you for the response

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.