Asus AC68


#22

Ohw that last one should be:

grep 'IPV[4,6]_ADDRESS\|PIHOLE_INTERFACE' /etc/pihole/setupVars.conf


#23

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
inet 10.1.1.240/24 brd 10.1.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fe80::c275:c91:b0e:89c9/64 scope link
valid_lft forever preferred_lft forever
pi@PiHole:~ $


#24

pi@PiHole:~ $ grep ‘IPV[4,6]_ADDRESS|PIHOLE_INTERFACE’ /etc/pihole/setupVars.conf
PIHOLE_INTERFACE=eth0
IPV4_ADDRESS=10.1.1.240/24
IPV6_ADDRESS=
pi@PiHole:~ $


#25

Above shows the Pi has IP 10.1.1.240 configured on the wlan0 (WiFi) network interface.

Above shows Pi-hole is configured to be used for the eth0 network interface.
But according to ip a, this eth0 interface is not connected “NO-CARRIER” and is not configured with an IP address:

Try run below one, select reconfigure, and when asked for the interfaces, select the wlan0 interface or both:

pihole -r

Afterwards, test again with the nslookup command on Pi:

nslookup pi.hole localhost

nslookup pi.hole 10.1.1.240

And on the client:

nslookup pi.hole 10.1.1.240


#26

I was beginning to think that might be where the problem lay…as when I ran pihole -r the first time it gave me an option of eth0 or wlan0 and the default was eth0 - which I choose without thinking and this Rpi 3b+ is connected wirelessly to the router. So the problem is that when I run pihole -r again it does not give me a choice of interfaces anymore…as it has baked in the first choice!..so I need to get pihole -r to do a fresh run. How would I do that. Thank you for your time and help, I really appreciate it.


#27

You need to select “Reconfigure”:


#28

Ah! of course…thank you!


#29

Afterwards, check if blocked domains have been pulled in:

echo '>stats' | nc localhost 4711

If not, below one forces a gravity pull:

pihole -g

And check after again:

echo '>stats' | nc localhost 4711

And oc the nslookup's !


#30

???
[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
[i] Reconfigure option selected
[✓] Disk space check
[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… up to date!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Using interface: eth0
[i] Using [i] Static IP already configured
[i] Unable to find IPv6 ULA/GUA address, IPv6 adblocking will not be enabled
[i] IPv4 address: 10.1.1.240/24
[i] IPv6 address:
[i] Web Interface On
[i] Web Server On
[i] Logging On.
[i] Privacy level 0 [i] Performing reconfiguration, skipping download of local repos
[✓] Resetting repository within /etc/.pihole…
[✓] Resetting repository within /var/www/html/admin…
[i] Main Dependency checks…
[✓] Checking for cron
[✓] Checking for curl
[✓] Checking for dnsutils
[✓] Checking for iputils-ping
[✓] Checking for lsof
[✓] Checking for netcat
[✓] Checking for psmisc
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[✓] Checking for idn2
[✓] Checking for sqlite3
[✓] Checking for libcap2-bin
[✓] Checking for dns-root-data
[✓] Checking for resolvconf
[✓] Checking for libcap2
[✓] Checking for lighttpd
[✓] Checking for php7.0-common
[✓] Checking for php7.0-cgi
[✓] Checking for php7.0-sqlite3

[✓] Enabling lighttpd service to start on reboot…

[i] FTL Checks…

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[✗] Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
[✗] FTL Engine not installed

???


#31

Set nameserver first before running pihole -r to reconfigure:

echo 'nameserver 8.8.8.8' | sudo tee /etc/resolv.conf

pihole -r


#32

pi@PiHole:~ $ sudo echo ‘nameserver 8.8.8.8’ | sudo tee /etc/resolv.conf
nameserver 8.8.8.8
pi@PiHole:~ $ pihole -r

[✓] Root user check

    .;;,.
    .ccccc:,.
     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
         .;cll.;;looo:.
             .. ','.
            .',,,,,,'.
          .',,,,,,,,,,.
        .',,,,,,,,,,,,....
      ....''',,,,,,,'.......
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........
      ........,,,,,,,'......
        ....',,,,,,,,,,,,.
           .',,,,,,,,,'.
            .',,,,,,'.
              ..'''.

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
[i] Reconfigure option selected
[✓] Disk space check
[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… 1 updates available
[i] It is recommended to update your OS after installing the Pi-hole!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Using interface: eth0
[i] Using [i] Static IP already configured
[i] Unable to find IPv6 ULA/GUA address, IPv6 adblocking will not be enabled
[i] IPv4 address: 10.1.1.240/24
[i] IPv6 address:
[i] Web Interface On
[i] Web Server On
[i] Logging On.
[i] Privacy level 0 [i] Performing reconfiguration, skipping download of local repos
[✓] Resetting repository within /etc/.pihole…
[✓] Resetting repository within /var/www/html/admin…
[i] Main Dependency checks…
[✓] Checking for cron
[✓] Checking for curl
[✓] Checking for dnsutils
[✓] Checking for iputils-ping
[✓] Checking for lsof
[✓] Checking for netcat
[✓] Checking for psmisc
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[✓] Checking for idn2
[✓] Checking for sqlite3
[✓] Checking for libcap2-bin
[✓] Checking for dns-root-data
[✓] Checking for resolvconf
[✓] Checking for libcap2
[✓] Checking for lighttpd
[✓] Checking for php7.0-common
[✓] Checking for php7.0-cgi
[✓] Checking for php7.0-sqlite3

[✓] Enabling lighttpd service to start on reboot…

[i] FTL Checks…

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[i] Latest FTL Binary already installed (v4.2.3). Confirming Checksum…
[i] Checksum correct. No need to download!
[✓] Checking for user ‘pihole’
[✓] Installing scripts from /etc/.pihole

[i] Installing configs from /etc/.pihole…
[i] Existing dnsmasq.conf found… it is not a Pi-hole file, leaving alone!
[✓] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf

[i] Installing blocking page…
[✓] Creating directory for blocking page, and copying files
[✗] Backing up index.lighttpd.html
No default index.lighttpd.html file found… not backing up

[✓] Installing sudoer file

[✓] Installing latest Cron script

[✓] Installing latest logrotate script
[i] Backing up /etc/dnsmasq.conf to /etc/dnsmasq.conf.old

[i] Skipping firewall configuration
[✓] man pages installed and database updated
[i] Testing if systemd-resolved is enabled
[i] Systemd-resolved is not enabled
[✓] Restarting lighttpd service…
[✓] Enabling lighttpd service to start on reboot…
[i] Restarting services…
[✓] Enabling pihole-FTL service to start on reboot…
[✓] Restarting pihole-FTL service…
[✓] Deleting existing list cache
[i] Pi-hole blocking is enabled
[i] Neutrino emissions detected…
[✓] Pulling blocklist source list into range

[i] Target: raw.githubusercontent.com (hosts)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: mirror1.malwaredomains.com (justdomains)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: sysctl.org (hosts)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: zeustracker.abuse.ch (blocklist.php?download=domainblocklist)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: s3.amazonaws.com (simple_tracking.txt)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: s3.amazonaws.com (simple_ad.txt)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[i] Target: hosts-file.net (ad_servers.txt)
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

[✓] Consolidating blocklists
[✓] Extracting domains from blocklists
[i] Number of domains being pulled in by gravity: 0
[✓] Removing duplicate domains
[i] Number of unique domains trapped in the Event Horizon: 0
[i] Number of whitelisted domains: 0
[i] Number of blacklisted domains: 2
[i] Number of regex filters: 0
[✓] Parsing domains into hosts format
[✓] Cleaning up stray matter

[✓] Force-reloading DNS service
[✓] DNS service is running
[✓] Pi-hole blocking is Enabled


#33

On Pi:

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471[1-8] '

echo '>stats' | nc localhost 4711

ip a

grep 'IPV[4,6]_ADDRESS\|PIHOLE_INTERFACE' /etc/pihole/setupVars.conf

nslookup pi.hole localhost

nslookup pi.hole 10.1.1.240


On client:

nslookup pi.hole 10.1.1.240

EDIT: ohw a reboot sometimes helps :wink:

sudo reboot


#34

Ohw and just to be sure, no alien config files that dont belong to Pi-hole (might want to edit out personal details you dont want to post) ?

sudo grep -v '^#\|^$' -R /etc/dnsmasq.*

EDIT: I forgot sudo


#35

pi@PiHole:~ $ sudo netstat -nltup | grep 'Proto|:53 |:67 |:80 |:471[1-8] ’
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2777/lighttpd
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 3000/pihole-FTL
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 3000/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 2777/lighttpd
tcp6 0 0 :::53 :::* LISTEN 3000/pihole-FTL
tcp6 0 0 ::1:4711 :::* LISTEN 3000/pihole-FTL
udp 0 0 0.0.0.0:53 0.0.0.0:* 3000/pihole-FTL
udp6 0 0 :::53 :::* 3000/pihole-FTL
pi@PiHole:~ $


#36

pi@PiHole:~ $ echo ‘>stats’ | nc localhost 4711
domains_being_blocked 2
dns_queries_today 10174
ads_blocked_today 0
ads_percentage_today 0.000000
unique_domains 65
queries_forwarded 10018
queries_cached 28
clients_ever_seen 1
unique_clients 1
dns_queries_all_types 10174
reply_NODATA 0
reply_NXDOMAIN 0
reply_CNAME 0
reply_IP 0
privacy_level 0
status enabled
—EOM—

^C


#37

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
inet 10.1.1.240/24 brd 10.1.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fe80::c275:c91:b0e:89c9/64 scope link
valid_lft forever preferred_lft forever


#38

pi@PiHole:~ $ grep ‘IPV[4,6]_ADDRESS|PIHOLE_INTERFACE’ /etc/pihole/setupVars.conf
PIHOLE_INTERFACE=eth0
IPV4_ADDRESS=10.1.1.240/24
IPV6_ADDRESS=


#39

pi@PiHole:~ $ nslookup pi.hole localhost
Server: localhost
Address: ::1#53

Name: pi.hole
Address: 10.1.1.240


#40

pi@PiHole:~ $ nslookup pi.hole 10.1.1.240
;; connection timed out; no servers could be reached


#41

What is Ohw???