Another iOS compatibility issue, but different

Expected Behaviour:

piHole working well on my iPhone and iPad too

Actual Behaviour:

piHole working on everything else

Debug Token:

https://tricorder.pi-hole.net/7bcebb56sw

Hi, i’m new to pihole. I set up in a couple hours and i want it to be “injected” into my router’s dhcp. I know this “injection” works because my smart tv automatically got recognized into pihole admin panel. iMac works fine too. iPhone and iPad instead, they don’t connect to piHole.

I’ve seen many issues of other people here complaining about their iDevices connecting to piHole but then having no access to the internet. Here instead i have no connection to piHole at all, and ads on the internet, of course.

Clicking the “i” in wifi settings and then going to DNS, i find it set to Automatic and as DNS i have"192.168.1.126" , which is my piHole ip, so it got “injected”, but it doesn’t work anyway. Even if i switch to manual , and i set the same address.

Can you please help me? Thank you guys :slight_smile:

UPDATE1: I also tried to disable router’s DHCP and enable piHole’s . It works good aswell, iPhone and iPad connect to it. In the settings they have 192.168.1.126 as only DNS server but still no good.

UPDATE2: I noticed this in my router’s dashboard:
58
It was damn strange. So i searched for them and understood they are my ISP’s DNS. I finally found this setting menu:


I tried deleting the 2 entries, disabling the 4 entries in the bottom but nothing, after any reboot they came back again stronger. I also tried to add on the top of them a rule going to 192.168.1.126 (my piHole), but doing so, it ended in a loop (probably) that didn’t resove any host on any device.

P.S: The update2 considerations probably might be useless if you consider update1, due to dhcp bypass, but i reported them anyway

I hope you guys can help me to find a solution because i really enjoy piHole and i’d love to use it on my Apple devices. Thank you

Your router seems to bypass any DNS related settings for your network.

One thing you can do is disable the router’s DHCP settings and enable Pi-hole as the DHCP server.

That way, everything that gets an DHCP lease (IP) gets the right settings straight from Pi-hole.

Based on your debug above, you DO have DHCP enabled however i don’t know if you have it disabled in the router.

Once you have that disabled (in the router) you need to release/renew on your devices as the lease might still be active on it (and that’s why it retains the settings).

Sometimes iOS devices don’t do it for some reason( own experience). What i found out works for a quick release/renew is to join a different WiFI network …

If you check UPDATE1, i have already enabled piHole DHCP and i can find my apple devices in the dhcp menu as connected and having received dns and ip from pihole’s dhcp server. So…

Try running a test on https://www.dnsleaktest.com/

You do have rpcbind running, i wonder if that’s taking over …

Running a test from an apple device right?

Yes.

You should see your IP (ISP provided) as your DNS.

That’s still not a guarantee that it’s going through Pi-hole though.

That’s not my pihole, right

Btw, even if i do it from my mac, which has pihole enabled and working, it’s the same result

Try going to flurry.com on your I-Phone.

It should not work and an entry should show up in your Pi-hole admin showing flurry.com blocked.

If that doesn’t work, then your device is definitely not using Pi-hole as it’s DNS.

Change the WiFi Parameters to manual and use one DNS only, the Pi-hole one.

Make sure no IPV6 IPs are there either.

It loads this website on my iphone with no problem, and in the quey logs i have no log about it.
The only query logs my iPhone logs into pihole are some random apple services at midnight, kinda like updates and stuff like that. No internet traffic gets logged

The parameters in wifi settings are already at manual , with only dns 192.168.1.126, my pihole. No ipv6 present

I don’t know if there’s a way to run a nslookup on the iphone (without jailbreak).

That would tell you exactly what DNS server is being queried.

From everything we discussed and tried, it should have worked.

I guess not, but i have downloaded an app like “Network Analyzer” and according to it, the dns is my piHole. :scream:

I cannot replicate it on my network, and I have a few Apple devices, all working flawlessly with Pi-hole as the DHCP server.

Maybe those sites are cached on iOS ?

Have you tried a different browser? Chrome or Firefox?

I usually browse with Chrome, tried ATM with Safari but same thing.
Tried also different websites, never visited. Ads, ads everywhere

Do you have IPv6 enabled on your network?

I don’t think this is an IOS issue, I think it is a router/ISP issue, where the router is providing alternate DNS that the clients can use.

I guess it’s disabled
36

In piHole settings it says "ipv6 address: " so i guess it’s disabled part 2

If you have a Windows client on your network, please post the output of ipconfig /all from that client.

My brother’s laptop is Windows but atm i can’t access it since it’s locked. I’ll try when he’ll come back and notify you asap. Thanks for the effort