After latest update - DNS service not running FTL offline

Hello!
I'm wondering if someone can look at my log file to see what I'm missing. DNS and FTL will not stay online after the last update.

Details about my system:
https://tricorder.pi-hole.net/iu7IemwH/

I removed and reinstalled pihole, still can't get it to stay online.

Sorry for the inconvenience you're experiencing. Your debug log contains a crash report even when there is not much information about what is causing the crash.

I'd like you to try

pihole checkout ftl fix/rate_limit_crash

which fixes a maybe similar crash reported recently.

Once the next Pi-hole version has been released, you can easily switch back using

pihole checkout master

I ran it, and it's now up and running again, thank you so much!!

Should I worry about the rate limit error that's coming from my router? I can turn it off, but not sure I want to do that?

Maryann

Do you see all queries coming from the router on the Query Log? If so, how did you configure you router? If you are able to change the router to hand out the Pi-hole as DNS server directly, this will allow you to see individual clients instead of only the router. This will also unleash a lot of additional power with individual settings for the devices in your network (if you ever need this). If your router does not support this, you can try switching the DHCP server from the router to the Pi-hole.

I have set router to use pihole as DNS server

I ended up reinstalling again today - I am back up and running, but still getting a ton of rate limiting from router. I can't figure out if there's a DNS loop somewhere - do you have any resources on how to check that? here is new log file: https://tricorder.pi-hole.net/L8LHKeJQ/ - does anything look incorrect?

Thanks so much for the assistance!!

Your router announced itself as DNS server of the network (dns-server: 192.168.1.1 from your debug log DHCP results). It performs the queries on the behold of the clients and bounces answers forth and back. The drawback is that Pi-hole cannot identify the individual requesting clients in this case and only sees one big client asking many queries. You have two options at this point:

  1. Increase the rate-limiting settings (or disable rate-limiting altogether). See https://docs.pi-hole.net/ftldns/configfile/#rate_limit for further details, or
  2. Switch the DHCP server from your router over to your Pi-hole (all network devices may need to be unplugged/re-plugged or restarted thereafter or you'll have to wait until their leases naturally expire). This would also unleash a lot of power as you would not only see which client made a query but also could define per-client rules like selective whitelisting, etc.

Hello!
I've updated my pihole to be the DHCP server, but am still seeing some rate limiting.

https://tricorder.pi-hole.net/TrqynRGN/

Is the DHCP settings on the pihole (192.168.1.1) correct? I think I may have to update the pihole on the system level? Let me know if I should change that.

They appear to be. 192.168.1.1 is your router, and Pi-hole is the DHCP server advertising itself as the DNS server.

ok, great - could it be the case that all devices on the network haven't fully updated (DHCP release and renew), and that could cause the multitude of requests from .1?

Yeah, that's likely the cause. Depending on how long your router's DHCP leases are valid, this can take some time. The easiest solution would be to power cycle them.

I'm still getting hundreds of thousands of requests from router - do you have any testing tools to recommend I use to try to figure out where all this traffic is coming from? Thanks!

Not trying to hijack the thread just didn't want to make another thread I'm experiencing the same issues I have implemented the fix above. The FTL and DNS service would just randomly stop and just wanted to provide my debug incase this is similar or different.

https://tricorder.pi-hole.net/4VVdNfWL/

Running a UDM Pro with the only DNS server being the pihole VM which is running on CentOS.

Thank you.

For starers you can check out the Pi-hole dashboard at http://pi.hole/admin and specifically the Top Domains and Top Ads tables.

I think the issue is the Orbi - there is an additional DNS service running on it for the parental controls we use. I think we're going to get a new router and move away from the Orbi - it's not worked well for us anyway. What happens is when we turn off the secondary DNS on the router (and point it solely at the pihole), it breaks all internet access to all devices. Once I add a secondary back in, service comes back. I still can't track down the loop between the orbi and the pihole that is hammering the pihole with DNS traffic that trips the rate limiting.