Ads werden angezeigt trotz "funktionierendem" pihole


#1

Lange Rede kurzer Sinn: Mir werden Ads angezeigt, obwohl pi-hole funktioniert. Ich bin seit der Installation vor etwa fünf Tagen jetzt bei 3900 queries und 1900 geblockten queries angekommen. Trotzdem ist überall noch reichlich Werbung vorhanden. Vorab kurzer Disclaimer: Das ist mein erstes Projekt mit dem raspberri pi; bei dummen Aussagen also bitte nicht steinigen.

Ich habe pi-hole gemäß der Anleitung auf der Homepage aufgesetzt und mich dann an den Thread zur Installation von pi-hole und fritzbox gehalten. Ich nutze die 3270 und bin Kunde der Telekom. Momentan nutze ich folgende Einstellungen:

Upstream DNS Servers habe ich cloudflare genommen.
Ich habe listen on all interfaces eingestellt.

In der Fritzbox habe ich als alternativen DNS für IPv4 eingetragen: 192.168.178.25 bzw. 192.168.178.26. (über /admin kann ich auch auf das webinterface zugreifen, sollte also das richtige sein)
für IPv6: fd00::xxx…
Die IP-Adressen werden mir unter network information auch so angezeigt. In der Fritzbox habe ich ULA eingeschaltet und als Prefix fd00 eingestellt.

Ich habe auch schon versucht den DHCP-Server von Pi-hole zu nutzen (den in der fritzbox habe ich natürlich ausgeschaltet). Das hat leider auch nicht funktioniert.
Könnte es an der fritzbox liegen? Die 3270 ist ja schon was älter. Gibt es noch andere Einstellungen an denen es liegen könnte? Über Hilfe würde ich mich sehr freuen.:tired_face:


#2

Ok

1 wie genau ist dein pi an die Fb angeschlossen ?

2 Pihole Settings DNS nur Cloudflare hinterlegt ?

3 wen der pi nur mit lan verbunden ist brauchst kein all interface der muss nur am eth0 listen

4 im der Fb hast du unter Netzwerk Heimnetz Nertzwrrkwinstelung IPv4 adresse
Unter Dns die feste ip vom Raspi eingetragen

5 Pihol Settings DNS

Never forward non-FQDNs
Beide aktive

Use Conditional Forwarding Aktive
ip Fb eintragen
Fritz.box

6
In der Fb hast du unter Netzwerk Heimnetz Nertzwerkeimstellungen ganz unten evtl. Die Einstellung ( Fb schon alt ) DNS-Rebind-Schutz
Da drängst du
pi.hole
Ein

Dann alles Speichen und beide geräde ein Neustart machen und alle geräde im Netz

Und einige Anzeige kan man nicht blocken den die Webseiten Betreiber denken mit und legen die Werbung als Teil ( Bilder ) Integriet in die Webseite


#3

Vielen Dank für deine Antwort. Es hat leider auch mit den neuen Einstellungen nicht funktioniert. Ich werde mal versuchen pi-hole neu aufzusetzen. Vielen Dank für deine Mühen.