Ads still filtering through

The issue I am facing:

Ads are still filtering through.

I have added all the possible clients on my network under Clients and grouped them under Default for now. I've added Adlists as URLs from Firebog and all of them have been applied to the Default group as well. Essentially, all adlists now apply to all clients?

On my router, I've disabled IPv6 and added the IP of my Debian machine as the DNS server for my LAN network. The rebooted the router so that all network devices can reconnect.

However, ads are still filtering through, especially the ones with known domains such as etc.

Details about my system:

I have Pi-Hole setup on a Debian 11 OS installed on PC Engines' APU2 hardware. Web server is Apache 2.4.56 along with PHP 8.2, and MariaDB 10.5.19-MariaDB-0+deb11u2. There is also a Nextcloud server running on the same hardware. While installing Pi-Hole, I opted yes for installing the Admin interface but no for the web server. I later installed the required sqlite3, xml, and intl modules.

Listed below is the Apache config for Pi-Hole,

<VirtualHost *.80>
	DocumentRoot /var/www/html/admin
	ErrorLog ${APACHE_LOG_DIR}/pihole-error.log
	CustomLog ${APACHE_LOG_DIR}/pihole-access.log combined
	LogLevel error

	<Directory "/var/www/html/admin">
		AllowOverride None
		Options None
		Order Deny,Allow
		Allow from localhost
		Deny from all


What I have changed since installing Pi-hole:

Nothing. Debug code is here:

Note that there is no need to do this because, in the absence of any custom group configuration, Pi-hole already assigns all adlists, domains (black/white lists) and clients to the built-in Default group as standard.

All adlists and domains/rules in a group are applied to all clients which are in that group. There's a worked per-client example in the docs.

You may have additional DNS servers being presented to clients by your router, or IPv6 may still be present in some form. It may be that your modded install has had unforseen consequences (the debug log which you uploaded will help staff determine that) Try the commands below, on a client which should be using Pi-hole, to see what it is using (replace the PIHOLE_IP in the final command with the IP address of your Pi-hole), and post the results here:

nslookup pi.hole
nslookup PIHOLE_IP

Also check if you can see these last two queries in the Query Log after you're ran them.

It works now as expected. I think it took a while for my router to propagate the DNS and be recognised. Thanks again for your help.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.