Ads in Firefox/Chrome android

#1

Hello,

Some weird things going on and trying to figure if there is a problem with my pi-hole or not.

-Checking with Firefox android at https://ads-blocker.com/testing/ - I CAN see ads
-Checking with Chrome android at https://ads-blocker.com/testing/ - I DONT see ads
-Checking with Firefox android+vpn* at https://ads-blocker.com/testing/ - I DONT see ads
(vpn*: connecting by 4G to my network through vpn that I have setup on my pi)

  • Some more tests on other websites I have seen the opposite. I see ads in Chrome but not in Firefox
    I can only guess this is a cache thing?

4G is always OFF while testing on my wifi.
I am not using any addons on the browsers/
I am also running avahi-daemon on my pi.

My debug token is: ub6mvt5xz9!

0 Likes

#2

Firefox has it’s own DNS setting in the browser. go to Firefox Options > General > Network Settings

And you will find the settings there. You can change it do the pi-hole there and set other options.

Here is a good thread on how DNS can be configured in Firefox:

0 Likes

#3

After some tests I noticed that Firefox browser in my mobile is totally ignoring the pi-hole.
On dnsleaktest.com:
Firefox android gave me the dns of my ISP
Chrome android gave me the dns of Cloudflare as they are set in pi-hole

Is there a way to configure DNS over HTTPS in Firefox android?
I go to about:config and doesn’t let me change the network.trr.bootstrapAddress to give my dns ip

0 Likes

#4

I remember that you have to set network.trr.mode to 0 (zero)

https://discourse.pi-hole.net/t/firefox-loads-ads-other-browsers-dont/14703/5

0 Likes

#5

You can also check configured DNS servers on Android (with & without VPN) with below ones in a terminal window:

getprop net.dns1

getprop net.dns2

getprop net.dns3

0 Likes

#6

Οk, after a lot of more tests the conclusion is that my android phone is bypassing pi-hole most of the time. I also disabled ipv6 from router to be sure and I could still see ads in browsers and other apps. So I ended up that this is a hard coded dns thing in my phone (Samsung s8 and a Xiaomi note 5)

I tried a DNS Changer app (works like local vpn) and pi-hole worked great. But the point is that I don’t wanna have an app in use to keep my custom dns up. Anyway to force that in my mobile? Changing the network settings of mobile with custom dns the pi-hole ip never worked too.

The last thing I wanna try is to setup ipv6 too for pi-hole.

0 Likes

#7

Stay away from IPv6 with Android. I use a APP named Netguard which offers more.

However I see still Alphabet running into firewall wihich blocks ‘rouge’ DNS servers from Google or even Huawei DNS server in China…and many others.
The DNS servers addresses are build in the official APP’s so I have block those IP adresses.

I don’t bending them over to the pihole and just let them out my network.

With Netguard I can block all APP’s and only give access to the Internet for APP’ that I am using.

0 Likes

#8

At last a solution here:

My Speedport Entry 2i router had 2 options for ipv6.
At first i had disabled DHCPv6 server and pi-hole worked at my dekstop only. Then I noticed a service called “RA service” which i disabled it too and now mobile clients don’t get ipv6 ips.
Pi-hole now works perfect in all devices but I noticed that web pages are loading way too slower now.
Is that my idea or does ipv6 do that?

0 Likes

closed #9

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes