403 - Forbidden -- Solution on Armbian (Ubuntun 18.04.2)

#1

After getting the 403 error, I searched the whole board an web for solutions and tried out everything mentioned. What helped me was activating the fastcgi module in lighttpd to get rid of the php restriction.

Many suggestions showed in the same direction and worked with “lighty-enable-mod fastcgi-php” and “service lighttpd force-reload” which ended for me in “Ignoring unknown module: fastcgi” and" Ignoring unknown module: fastcgi-php". So this didn’t do the job on my system.

I found a workaround for php and lighttpd in the net that solved the problem.

Installing the latest dnsmasq, php7.2 and php7.2-cgi

sudo apt-get install dnsmasq
sudo apt-get install php7.2
sudo apt-get install php7.2-cgi

Then editing the /etc/lighttpd/lighttpd.conf:

  1. Adding fastcgi to the server modules
server.modules = (
        "mod_access",
        "mod_fastcgi",
        "mod_accesslog",
        "mod_auth",
        "mod_expire",
        "mod_compress",
        "mod_redirect",
        "mod_setenv",
        "mod_rewrite"
)
  1. putting this at the end:
fastcgi.server = ( ".php" => (( 
                    "bin-path" => "/usr/bin/php-cgi",
                    "socket" => "/tmp/php.sock" 
                )))

After reboot the admin-page was accessible again.

Hope this could help some other guys!

Alex

1 Like
Keine Weboberfläche mehr nach Update