1. Local devices' hostnames not resolved on Wifi repeaters (only on Wifi router), 2. Setup in general ok?

The issue I am facing:
Actually, I have 2 issues for which I kindly ask for your help and hints:

  1. Whereas my router shows local devices' hostnames properly resolved, my Wifi repeaters don't.
  2. I am not sure whether my setup in general (independent of issue No. 1) is correct and makes sense, and I would appreciate to learn from you what you think about it.

The setup as such works, i.e. external web sites are properly shown. Loading times seem to be ok (the connection is a 1 Gbit cable line).

Details about my system:
I have 2 Pi-Holes running idependently on 2 VMs (Synology server) with Debian, named:

  1. DNS1.fritz.box (192.168.178.21)
  2. DNS2.fritz.box (192.168.178.25)

Besides, on each Debian runs unbound.

My router is a Fritz!Box 7490 from AVM, named fb7490.fritz.box, and sits behind a cable modem. It serves as DHCP, i.e. the local devices receive their IPs from the Fritz!Box 7490. Only IPv4 is enabled, IPv6 is disabled.

Besides, I have 2 Fritz!Repeater 3000, also from AVM, all set up as a mesh (showing the mesh symbol) and inheriting the settings from the Fritz!Box 7490 (which is the mesh master).

The settings on the Fritzbox 7490 and on the 2 Pi-holes are shown in the screenshots. As you can see, I should update the 2 Pi-holes, which I will do within due course. Apart from that, do you see any problems with these settings? What would I have to change in order to get resolved local devices' hostnames also on the 2 Wifi repeaters? Are there any other settings that should amend for more security, stability, and/or for other reasons?

Thank you so much for sharing your thoughts and helping me understanding if all is well or what should be amended! :slight_smile:

What I have changed since installing Pi-hole:
Not applicable, i.e. I have not changed anything - this is my initial setup.

Screenshots:
AVM Fritz!Box 7490:

Pi-hole 1 = DNS1.fritz.box (192.168.178.21):



Pi-hole 2 = DNS2.fritz.box (192.168.178.25):



I have difficulties understanding your issue, as none of your many screenshots seems to demonstrate any actual resolution problems.

Apart from that, your overall configuration seems flawed.
You've configured your FB to use Pi-hole as its upstream DNS server, and as a DoT server at that.

Pi-hole only supports DNS, so without additional software, you won't be able to use it via DoT.

In addition, it would be preferred if you configured Pi-hole as your router's local DNS server, which is quite possible for a FB.
Doing that would also avoid the partial DNS loop that you've introduced by having Pi-hole as your router's upstream and enabling Conditional Forwarding in your Pi-hole at the same time.

For additonal guidance, please have a read of https://docs.pi-hole.net/routers/fritzbox/ (also available in German).

1 Like

Thanks for your reply, and please forgive me my noob question: While you wrote that my screenshots do not seem to demonstrate any actual resolution problems, you then explain that in fact I did set this up wrongly (that's what I understand). So this leaves me a bit puzzled. As I am not a native English speaker, I might have misunderstood you, though, in some regard.

When I read on, I understand that my setup cannot possibly work, but it does, i.e. I have working connections, plausible entries in the Pi-hole's query list/log, but I am unhappy about the local devices' names not resolving in the Wifi Routers, where instead names like "PC-192.168.178.74" etc. are shown. Is this somehow related with what you wrote about my flawed config?

And I do not understand what you meant by "without additional software...". I mentioned 'unbounb' (which runs on both Pi-holes - installed and set up following this guide), and I thought that the setup for this is correct as shown on my screenshots.

Does my reply make any sense to you? If not, please be patient with me. :wink: Thank you! :slight_smile:

PS:

But it is setup like this, or isn't it? As you can see on the first screenshot, IPs 192.168.178.21 and .25 (= Pi-Hole No. 1 and No. 2) are the primary and alternative DNS servers on the Fritz!Box router.

Your screenshots do not document a single example for your stated issue of non-resolved local hostnames. Instead, they partially document how you configured your router and Pi-hole.

Yes, as apart from your issue (i.e. independent from it), the parts of the configuration you've shown are flawed as already explained.

No, I didn't say that.
I said that you won't be able to use Pi-hole via DoT.
With your current configuration, your FB will fall back to plain unencrypted DNS as it cannot communicate with Pi-hole via encrypted DoT.

No, it isn't.

As already indicated, those are your router's upstream DNS servers.
Your FB will forward any DNS queries -its own as well as any it receives by a client that uses your FB for DNS- to one of those IP addresses. In addition, one of your screenshots shows that you are still distributing your FB's IP address as local DNS server via DHCP.

Please take the time to read through the link to our FritzBox configuration guide I've provided above.

I hope that I have now a better understanding - thanks for pointing me to the guide.

Now in the FB 7190 (192.168.178.1) network settings, I have set the Pi-Hole's IP (192.168.178.21) as Local DNS server. The second Pi-Hole (192.168.178.25) cannot be set there, but I just let it running, so I can set it manually if I have to stop the primary one. Now - as also explained in the guide - the Pi-Hole's query log shows all devices individually and not only the FB 7190.

The Repeaters still do not resolve the devices' names but instead only show somwthing like e.g. "PC-192-168-178-74", but maybe this has nothing to do with Pi-Hole. Or does it?

I am still struggling with unbound, which does not work now (no routes found). When I use e.g. OpenDNS instead, it works, so I must look further into my unbound setup, I guess.

Use of DNSSEC is set on the Pi-Hole as on the FB 7490.

Could be. Repeaters are pretty dumb devices, I wouldn't expect them to issue DNS requests.

As long as none of your clients has problems requesting (especially local) DNS resolution through a repeater, I wouldn't consider that an issue.
If you do run in such issues, please demonstrate by providing the output for some failing nslookups form such a repeater-connected client.

All clients, connected via Cat or Wifi to the main FB 7490 router or to the Repeaters never showed problems with nslookups. I had meant that the Repeaters showed (and still show) something like e.g. "PC-192-168-178-74" in their logs and GUI instead of e.g. "Streaming stick". It is very likely that the Repeaters do not issue DNS requests as you wrote. So my "issue" rather seems to be Repeater-related. Nevertheless, I am happy to have asked here in this forum and that your replied, because else, I would still use a flawed setup. :wink: